You are here

Tiy's tweet

If you are following the link by @Tiy you need the mumble client from http://mumble.sf.net/ (Not the compatible version)
and connect using mumble to mumble.cuberealms.com